Articulate and Moodle 2.0

Hi

I'm working on a project for an organisation that has just fired up a Moodle 2.0 site.

Within the Moodle community there is quite an angst ridden issue of Articulate type packages that use SWF and FLV files not operating propoerly, or at all in the new Moodle Achitecture.

All my previous experience has been with Moodle 1.9 and allmy aticulate projects work just fine. I have tried to load an Articulate package into the new Moodle 2.0 site, but am both confused and confounded and have not yet found the solution.

Does anybody at Articulate know about these issue and what the goss is on fixes and future developments.

Cheers

Keith

9 Replies
Steve Flowers

TBH, I think this is a Moodle issue that has to do with they way they're storing files in 2.0. We've had a few issues with Moodle deployments as well (the elements you describe above) with course files that work everywhere else and shouldn't fail... but fail to load dependencies and media.

I'm not sure there is anything the Articulate folks can do short of contributing to Moodle I could be wrong but I think it's entirely a Moodle problem.

Bill Osborn

I too am having the same issue with Moodle 2.0. None of my Engage pieces that have an FLV video are working. It simply shows the circle pre-loader and never goes any further. I have not yet taken the time to upload any other courses with various engage interactions to see if they too suffer from this issue. I would also be interested to know what other out there are using for their course settings when using Articulate courses.

Todd Thornton

Not sure if you guys are specifically referring to SCORM packages, but I've been using Moodle for years and SCORM support has never been good and likely will not be a priority going forward either. In the 1.9 series, really it wasn't until 1.9.4 that SCORM was very usable. As much as you don't want to hear this, IMHO your best bet if it's a new site is to go back and start fresh with a new install of 1.9.11 for the time being as I highly doubt 2.0 will really be ready for prime time until the end of this year.

It appears to me there's very few institutions using Moodle 2.0 in a real production environment at this point. I believe some brave colleges in the US are planning to switch over this summer and by late fall you might see something relatively stable after you get some real world heavy uses. (The last time I tested 2.0 the performance/lag/load times were just awful)

In terms of the new file structure, unless it changes in the future it seems to me those with lots of files/resources/courses will almost need to use a separate repository like Alfresco to get anything similar to the functionality/ease of use they have been accustomed to. I've been using Moodle every day for the past 7 years and the new file system is the most "unintuitive" thing I've even seen.

Todd

Brian Batt

Hi Bill,

If you have included FLV or MP4 movies in your Presenter 09 presentation, Quizmaker '09 quiz, or Engage '09 interaction that do not play in your published output, please review the following related article(s):

Presenter '09:

http://www.articulate.com/support/presenter09/kb/?p=2203

Quizmaker '09:

http://www.articulate.com/support/quizmaker09/kb/?p=853

Engage '09:

http://www.articulate.com/support/engage09/kb/?p=544

Alice W.

I really need some guidance from someone using Moodle 2 or above.  We have recently converted our Moodle from 1.9 to 2.5.  So, all the existing engage files and storyline files seem to work fine after the conversion.  However, when I try to add an engage file after the upgrade, I am having a hard time trying to figure out how to add the file onto moodle v2.5, and be able to display the engage file within a moodle content page.  Does anyone know what is the proper way to make this work?  I need to add the engage zipped file to the server and then somehow get to the url to the .swf file, and then embed that file inside a moodle content page.   Can someone please help?