After a course is resumed, it is "forgetting" the results of previously answered questions

HI all,


I created quite a lengthy course with following features:

Questions from a question bank scattered throughout the course
Unlimited attempts at all questions - so users cannot progress until they get a question correct
Set to "always resume"
Completion tracking as "Passed/incomplete"
Results slide based on successful completion of all slide

I've had a user come back to me with the following issue:

Course spends a long time buffering/lot of lag (this happens sometimes - there is a lot of video content in the material)
They exit the course due to excessive lag
They re-enter the course and it resumes where they left off
When they get to the final results slide, it tells them they have failed
They review their answers using the link from the results slide and it shows all answers as being answered correctly.

The net result is they have to sift through all the slides again to find the questions to re-answer them in one go. As the course material is locked (so that they have to view the full contents of every slide), this takes a long time.

I suspect that LMS is not "remembering" the questions they have answered prior to exiting the course, and hence failing them. Though when they then review the quiz, we can see that the answers are being remembered somewhere!


I tested this myself before I released the course - I progressed partly through the material, exited the course, went back in, and got to the successful results slide with no problems.


Has anybody seen this issue? Is there a reason why this would only be presenting for some users and not others? Would it have anything to do with the excessive "buffering" state that these users are also seeing? Is there anything else which could cause a "failed" results slide in these circumstances?


Thanks all in advance


9 Replies
Crystal Horn

Hi Michelle.  I have a couple of questions that might help me get to the bottom of what's happening here.

  • Do you know what browser the learner is using?  Is it possible they're on an older version of Internet Explorer?  I like to use to get that information from folks.
  • What format did you choose when publishing (HTML5 only, HTML5 / Flash fallback, etc)?
  • Are your slides in the question bank set to "reset initial state" or "automatically decide" when revisiting?  You can check the slide properties of your question bank question slides.

Thanks for the information!

Michelle M

Hi Crystal,

Thank you for your response, and sorry for the late reply! Thankfully no other users have reported this error, so it slipped off my radar, but I'd like to understand the error all the same.

Answers to your queries

  • Internet explorer 11.0
  • HTML5/Flash fallback
  • "Automatically decide" - I admit I never noticed that the questions themselves had resume options
Michelle M

Hi Leslie,

Yesterday I reviewed all the feedback I'd received from users not only on this module (call it Module 1) but also for another module (call it module 2). I'd received feedback for a similar issue with module 2, where users were getting to the end being told they had received "0%" in the quiz - despite the fact that was impossible!

I'm wondering if the issue might not be related to the questions being answered, but to how the course is getting tracked.

Towards the end of both module 1 and module 2, there is a branch, where the course asks "will you be acting as a quality reviewer?". If you select yes you are shown some additional slides before proceeding to the end of the course, but there are no additional questions. So selecting "no" should have no effect on the quiz results. The users who reported the error had said they'd selected "No"

But I'm wondering if I had accidentally asked Articulate to track course completion by the number of slides viewed, would this have led to an error like this? Persons who selected "No" would not have viewed all the slides and hence may not be getting their completion reported correctly? Though even if that were the case, could it have caused the results slide to report "0%"?

Is there any way to check was settings you had on a course after it has been published?

Leslie, re your answer, I am going to ask the other users who reported this problem what browser they were user.

Thanks all,


Michelle M

I've checked the settings of both modules as advised by Leslie.

Both modules are set as below

  • LMS reporting "Passed/Incomplete"
  • Track using quiz result [so NOT number of slides viewed]

So I'm still not sure why users are getting marked as getting 0% on the quiz....strange. 

All users who reported errors are using Internet explorer 11.0. This is the default browser within our organisation so I'm assuming the dozens of users who completed these modules with no issues also used this browser.

Michelle M

I can't share publicly but I can share privately.


I got an interesting new clue -  over the weekend a user tried to complete Module 1 (this is the module I am sending to you - the names might be confusing as my .story file is numbered differently!). As mentioned above, this Module has questions from a question bank sprinkled throughout it, and they are all set to "unlimited" attempts - so a user should not be able to progress until they have successfully answered the question.


However this user says they got some questions wrong, got to the end, were told they had not passed and (quote) "The system did send me back to repeat the relevant sections which is fine but when the quiz pops up it will not let me reselect different answers."


So it sounds as if they are being allowed to progress throughout the course even if they get a question wrong - I thought I had it set up such that this could not happen.


If you spot any settings I have wrong on the .story file I'd love to finally get to the bottom of this! :)