Alignment of a layer moves up and down

I am having an issue with layers on a particular slide not aligning with the base layer or first layer. I have buttons/boxes that you click on in the base layer that display the various layers and I have selected some of the base layer to be visible. Layer 1 works fine, all triggers etc. work fine, but what happens when you click on the button/box to trigger layer two (and the same for layer 3) is that the entire slide view of the layer and background move vertically up a few pixels! Then when you click on the button/box to see layer 1 again, everything moves back down where it should be. This is not visible when I am designing the slide, only in preview mode. I've attached this part of my project. 

3 Replies
Ben McKenna

Hey Jenny,

This is very bizarre - haven't seen anything like it before. But after playing around with your file it looks like your second button's background shape has a typo in the name of its visited state (you've entered it as "Visisted"), which means Storyline would now be treating it as a custom state instead of an in-built state. Don't ask me how or why this would affect things, but I duplicated your visisted state, corrected the typo, and linked your trigger to the visited state instead. It all seemed to work after that.

And just because I was curious, I went back to your original file and made the Visisted bigger, and lo and behold: that made the jump bigger too. It looks like the entire slide was shifting down to accommodate the box, but only when you clicked a certain part of the button. Weird!

Hope this helps

Jenny Brewer

Oh my! I am so glad you caught that! I read something recently about custom states vs. built in states, but it did not register that this issue could be tied to that concept, etc. Basically, I NEVER would have though of that, so you are my Hero of the day Ben!! Thank you for jumping in so quickly to help!

Crystal Horn

Hi Jenny!  I took Ben's advice a bit further - good sleuthing, Ben! :)

To simplify your slide, I removed the group.  I placed the text directly on the rectangle tabs rather than creating a group out of the rectangle and two additional text boxes.  Does that work for you?

Now, you can just use the built-in states which change without triggers.  I don't have to create a trigger for the hover, visited or selected states on the rectangle tabs because the functionality is built into those states!  And because it's just one object now (rather than a group), the states should work smoothly.

I've seen instances where you use a trigger to change the state to a built-in state, and the results are a bit wonky (technical term).  By keeping it streamlined, those objects and layers should behave better.

Let me know what you think!