Assessments not completing properly in Safari

For our post course assessments in Storyline 3 we use variables to track when a user gets a question correct so that we can allow users to retake only missed questions on re-test.  Questions types are T/F, Multiple Choice/Multiple Select. On the retest we set up triggers that will change the state of the radio button/checkbox based on the state (True) of the question variable value. The test will continue to allow retesting until the user gets all questions correct.   

We have used this model successfully for a couple of years, but with a recent course the tests work properly on a PC (IE11) but when we test on an iPad using Safari the test will not complete even when all questions are answered correctly.

The course is published to SCORM 1.2 and works properly through our LMS on PCs, which to me indicates that the course itself is working properly, but for some reason variable values are not being retained in Safari. 

4 Replies
Vincent Scoma

Hey Shawn,

Thank you for sharing those details about your course! That is odd that the course will not complete when using an iPad. A couple of questions for you: 

  • Do you happen to know which iOS the iPad is using? 
  • Just to clarify, were you using the iPad's touchscreen keyboard or a wireless keyboard when taking the course? 

If you're able to share the .story file with us for testing, that would be great! You can also send it privately to our Support Engineers by using this link. We'll delete it as soon as we're done troubleshooting. 

Shawn Stiles

Hi Vincent, 

I was testing using an iPad Air 2 with iOS 12.3.1, but we had multiple users with various iPad models try this as well with the same result. 

The courses were developed using Storyline 3 running update

Our course design does not require the use of a keyboard when taking the courses, so everything was touch screen. I also ensured that the question hot spots encompassed the radio button/checkbox as well as the text.

As part of my continued testing, after confirming all settings and variables, I decided to see what would happen if I published the course using Storyline 360.  I only opened the story file and published using the previously  saved settings that were used for publishing in Storyline 3.  When I uploaded the file to our LMS (staging environment where all courses are tested) using SCORM 1.2 and tested the course again, the tests worked correctly on the iPad, and I had a number of other users also test on iPad and all reported that the assessments were performing correctly using our missed question functionality.  

Based on the current testing results between SL3 and SL360, is there a way I can move back to a previous build of SL3 to see if there is any difference in performance before I installed the last SL3 update?  

I would need to get approval to share the file with your support staff. 

Shawn Stiles

Hi Vincent, 

One of my colleagues is running and older build of Storyline 3 (3.2.132130) so I requested that they publish the course for me using all of the same settings.  After uploading the course to our LMS I had some of the people involved with the initial testing check the newly published course. course on their iPads. This time they were able to successfully complete the assessment as programmed.

I went even further and reinstalled Storyline 3 Update 5:3.5.16548.0 and republished/re-tested the course and it performed correctly on the iPad. 

Based on the troubleshooting we've conducted using 2 different versions/builds of Storyline 3 and  using Storyline 360 as well as successfully testing the course on the iPads published with the various versions. I believe the root of the initial problem may be the current build of Storyline 3 (

For now I'm going to stay with the previous build to complete my project. 

Vincent Scoma

Hey Shawn, 

Thank you for confirming and for providing those details! I really appreciate the testing you have done as well!  If you do receive approval to share your file, please feel free to send it privately to our Support Engineers for further troubleshooting. 

I'm glad you were able to get around the issue by rolling back to a previous update.