Audio can't be heard on iPhone when in "Silent On" mode

Hi Articulate Community,

I created three courses in Storyline 360 (v3.37.21614.0) and published to SCORM. When testing on an iPhone (8 Plus, iOS 13.3.1), the audio in one of the courses acts differently than the other two: 

For two of the courses, whether the iPhone is set to "Silent On" or "Silent Off", the user can hear the audio tracks through the speaker on the phone (or using earbuds) when playing the course - tested and verified in Review360, on our Saba LMS platform, and on SCORM Cloud.

However, for the third course if the iPhone is set to "Silent On" the user cannot hear the course audio through the iPhone speaker. The audio files do play but the user cannot hear the audio.  BUT, in this course if the iPhone is set to "Silent On" and the user is using earbuds then they can hear the course audio. 

Have tested this on our LMS (Saba), on SCORM Cloud, and on Review360 with same results. The three courses were published exactly the same so not sure why it's only happening to one course. Anyone have ideas?

 

 

 

2 Replies
Vincent Pincaro

Hi, Shonna! I am happy to help with your first post, and hoping I can. I am also hoping you're well and safe.

To make sure that we are precisely on the same page, there were 3 courses tested using an iPhone 8 Plus. It should make sense that the expectation is for all these 3 to behave in the same manner. Strangely, one course behaves differently. For this, when the iPhone is set on Silent, it has no sound when "Speaker" is the output but has a sound when earbuds are plugged in. I hope my grasp of the issue is correct and please feel free to clarify my understanding.

From this understanding, what's very peculiar is that this one module seems to be behaving correctly while the other two are not. You may refer to this thread elucidated by Ashley, one of Articulate's staff.   

I have some questions to help me isolate further:

  • At this point, the issue seems to be pointing more on the irregularity of the 2 files. Were all the 3 courses created during the same sitting? or the two files were made on one day and that one file was finished on another. If Yes, there could be something distinct for each of these days (e.g. software update was performed for one). In this situation, you may try importing all the 3 courses again following these steps to attempt making the file properties common for all. 
  • Are you testing all 3 courses using one browser (e.g. Safari) on the iPhone? If yes, can you try another browser or set of browsers (Chrome, Opera, Firefox, etc.) to observe if the behavior will be consistent?
  • Is there another iPhone to test your files? There are situations that point to iOS/Android OS irregularities. This can be a noteworthy observation. 

If it is convenient for you to share the files, it will be helpful. Thank you and keep in touch. 

Shonna Falco

Hi there,

All three courses were created with the same version of Storyline 360 and by the same person (me). I did not create them all on the same day but within a matter of a week or two. The one that behaves differently is the second one I created; the first and third each behave the same (when in Silent mode you can still hear audio through the iPhone speaker). 

The thread that you shared is interesting but Ashley suggests that if an iPhone is set to Silent On the learner should not hear the course audio through the speaker (indicating one of my three courses is behaving correctly and the other two are not). 

We have tested on three different iPhones, all 8 Plus. We have also tested six other courses we built in the last few weeks and all six do play audio through the iPhone speaker when in Silent mode. Also, this is as Apple intends as here is their position:  In silent mode, you are unable to hear ringtones and alerts, but all other sounds like music and videos will still play

We are testing through Safari currently as that is the browser that our users will access from their iPhones.

So, either 8 of our new courses are not behaving correctly and one is, or 8 are behaving correctly and one isn't. 

Any additional info is appreciated! I will check to see if ok to send my .story file.