8 Replies
Crystal Horn

Hi there, Valesa!  You mentioned that the videos are external.  Are you using an embed code to bring them into Storyline 360?  Can you tell if there are any parameters added to the embed code to mute the audio, or if the video is also muted in its host location?

If I'm not quite understanding, just let me know!

Valesa Clouse

Hello Crystal, 

You are understanding what I am asking. However, I didn't change the iframe code (shown below). The code is the same as it has been and it worked fine before. The video is hosted on an internal MediaConnect site and has not been changed. The source is not muted. 

The main changes I have made to the SL file is add a custom player with "Jump to" triggers. I did find a discussion on Storyline 2 (I think) that had this issue previously where the audio didn't play after a "jump to" was used. However, the discussion said that error was corrected. 

 

 

<iframe id="kaltura_player" src="https://cdnapisec.kaltura.com/p/1969891/sp/196989100/embedIframeJs/uiconf_id/35151451/partner_id/1969891?iframeembed=true&playerId=kaltura_player&entry_id=1_w6uslm3f&flashvars[streamerType]=auto&amp;flashvars[localizationCode]=en&amp;flashvars[leadWithHTML5]=true&amp;flashvars[sideBarContainer.plugin]=true&amp;flashvars[sideBarContainer.position]=left&amp;flashvars[sideBarContainer.clickToClose]=true&amp;flashvars[chapters.plugin]=true&amp;flashvars[chapters.layout]=vertical&amp;flashvars[chapters.thumbnailRotator]=false&amp;flashvars[streamSelector.plugin]=true&amp;flashvars[EmbedPlayer.SpinnerTarget]=videoHolder&amp;flashvars[dualScreen.plugin]=true&amp;&wid=1_b793m5s1" width="608" height="402" allowfullscreen webkitallowfullscreen mozAllowFullScreen allow="autoplay *; fullscreen *; encrypted-media *" frameborder="0" title="Kaltura Player"></iframe>

 

P.S. I don't know how to read that code. :) Also, I did submit a support case for this problem. 

Thanks,

Valesa

Leslie McKerchie

Hello Corinne and welcome to E-Learning Heroes 😊

Thanks for reaching out and sharing that you're experiencing a similar issue. I was able to take a look at the support case that Valesa worked on with our team.

Keep in mind, this was reported well over a year ago and what they were experiencing was due to a Chrome change that we documented here.

Learners using Chrome 66+ will see a play button when they launch or resume a course with a video on the first slide. Clicking the play button starts the course and allows the video to play. Videos on other slides should autoplay as expected (unless your slides are set to advance automatically without user interaction).

Does this fit what you are seeing as well?

Daniel Gottron

Hello Leslie and team,

Thank you for your answer. However, the problem is not with the Autoplay starting to play the video. That is working fine. 

The problem is when the video automatically starts playing, on the slide, on entry.  It is MUTED and a little popup appears on the video telling the viewer "Unmute". By the time the viewer can respond they miss the first part of the audio on the video. 

I am experiencing the same problem. 

I tried adding a short text into, that makes the user clicks a "Next" button, to jump to a cue point. No luck....

Please advise, thank you.

Daniel

Ren Gomez

Hi Daniel,

Thanks for sharing that image of your course! I'm not familiar with an Unmute button appearing at the start of a slide with audio. Unless it was custom built, Storyline will default to audio playing automatically unless triggered.

One other place to check is the Audio Tools: Options when selecting the audio file. Can you ensure the volume isn't set to Mute?

If the button is custom-built, share your .story file with our support team, as they'll be able to dig deeper into the issue and provide some guidance!