Best Way to Avoid Blurry Videos

I've been reading a lot of posts about how to fix blurry videos in published Storyline files. I've got that same problem. My videos are avis and they look find in the preview. When I publish they are very blurry.

Can someone please help distill all of these different tips into a clear list of how to best record videos? Is it that they need to be a .mov? Does the recording field need to be a specific size? What is the relationship of the story file screen size in comparison to the recorded video?

Thank you for your help!

Michelle

7 Replies
Ashley Terwilliger

Hi Michelle,

I think that some of the "best practices" will depend on how you plan to deploy the course to your users - and your own preferences. 

This thread includes a lot of community members thoughts on screen size, locking the player size, etc. that may help you out. 

The AVI videos that you load in will be converted to MP4 on the publish as described in this tutorial.  Also, Storyline will compress your video to ensure the highest possible quality at the lowest possible size. A number of community members have reported using this solution from Mike Enders to keep the quality associated with their original video. 

Joe Chabot

IF your content is solely video content, I found that rather than going through the proper channels of publishing to video with the publisher, simply, right click on video object in the timeline, choose Show in Media Library. When the media presents in the Media library, you can choose to export it. When you export the content the video comes out perfectly with no blur at all. This is ideal in the case where you may be creating a webcast or something like that with no interactivity and only video playback with voiceover. I was really glad to find this is an option because the rendering through the publish tool is horrendously fuzzy even at the highest setting and captured in HD dimensions.

Mary Hanna

One method that has worked for me to improve the video quality within published slides is the following:

1.  Determine the resolution of the screen you used to record the video.  For example, my monitor is 1920 x 1080.  

2.  Choose the higher of the two dimensions (e.g., 1920).  Set your story size using that dimension and a corresponding dimension that maintains a 4:3 ratio.  For example, I've set my story size to 1920 x 1440.  Choose the option to lock the aspect ratio.

3.  When you publish:  Customize the "Quality" options in the "Properties" section of the publish menu to the highest quality levels for video and image qualities.  

Note that the clarity of the video (in my experience) is higher in published mode than in preview mode using this method.  Publish your slide/scene/project to assess the results.

Hope this helps.

Gerry Wasiluk

As for another viewpoint . . .

I usually "gently and friendly" push back on courses being so big on the screen or video being fullscreen.  Some things have to be but others don't (e.g., a talking head of a speaker)

I prefer using a player size that works well both on PC screens and on tablets like the iPad.  For that I use 960 x 540 (when using any of the Articulate bottom controls or nav) or 960 x 600 (when using no bottom controls and supplying my own nav).  Those sizes look good both on PCs/notebooks and on iPads with a minimal of scaling.  I also get smaller courses (helpful when some LMS's restrict total storage size) and "friendlier courses" to download on the network.

I'll then produce my source videos at hi-res and something like 1920 x 1080 and I'll let SL360 size them down to what I need.  So far, knock on wood, this also always worked for me.  In those cases it does not, I try to size the source video as best I can to its onscreen size in Storyline.

William Everhart

I recently ran into a similar issue with blurry video content from Camtasia. Previewing in Camtasia or any other video platform revealed the the video was indeed high definition. When I placed the video into Storyline and published, the result was a blurry or pixelated video. You could definitely tell that there was some heavy compression going on behind the scenes. 

To resolve this particular issue, I rendered my Camtasia project again but I changed the H.264 profile setting to High. The resulting video was perfect. 

The solution offered by Mike Enders would have definitely worked. Unfortunately it requires an extra effort that would surely be forgotten when the project is updated in the future. I hope that my solution is one that will help others as it requires no extra effort after the Storyline file is published.

Madhan Raja Aravamudhan

We ran into a similar issue and found a round about. Try following these steps: 

1. Publish your course as a SCORM output.

If your SCORM file is zipped, unzip the file.

2. Locate the Video output in the SCORM package (I suppose it should be inside the External Content folder)

3. Replace the Video output with your actual video. Make sure you change the name of the video you are replacing as the name of the video that is present in the External Content folder.

4. Open the HTML file and you will see your video running with the actual video quality.

Important note: Videos published using Articulate are compressed; when you follow the aforementioned steps, you are using video files in their original form with no compression. This results in increased size of your SCORM package. And that's a con.