Bookmarking/Resume Issue

Hello. I have a course that contains 4 scenes (1 main scene with 3 branches). Each of the 3 branching scenes contain knowledge check questions drawn from their associated question bank. Upon completing the questions, the learner is returned to the main scene's main menu via a trigger I have set on the last question to return to that slide (i.e. jump to slide 1.10). However, when testing in our LMS, I have found that the bookmarking/resume is not returning me to where I last left off. I am returned to the last question I answered. 

Question 1: Would it make a difference if the questions were within the scene as opposed to them being drawn from the question banks? 

Question 2: If no to the above, what type of variables can I perhaps set up, if any, to indicate that the last question slide was viewed and answered prior to the learner returning to the main menu? 

Thank you =)

 

7 Replies
Matthew Bibby
Susan Rice

However, when testing in our LMS, I have found that the bookmarking/resume is not returning me to where I last left off. I am returned to the last question I answered. 

This suggests that you may be hitting the rather low suspend data limits in SCORM 1.2.

Are you able to publish to SCORM 2004 3rd Edition?

Susan Rice

Hi Matthew. Thank you for your response. That thought about the suspend data limits did cross my mind at first but it's not a very long module and the majority of the slides are set to reset to initial state to help prevent reaching the data limits. Also, the course is only about 40 slides in total and only 8 assessment questions which are not graded. Unfortunately, we cannot publish to SCORM 2004 at this time in our LMS. I've attached a sample of the module to help convey the issue. 

Lauren Connelly

Hi Susan!

Thank you for attaching your file! I was able to view the course in Storyline 360. I see that you have the slides set to "Automatically Decide" when the user returns to a slide. If you change it to "Return to Saved State" than the user will return to the last slide viewed. This is what that would look like.

Can you make those changes and view in your LMS? Let me know what you come across!

Susan Rice

Hi Lauren! Thank you for the suggestion to try. I changed all of the slides to "Return to saved state" with the exception of the question slides that need to remain as "Reset to initial state" and am still having the same issue unfortunately. The one thing I have pinpointed down to be the possible cause are the 2 triggers that are on the correct and incorrect slide layers of the last question slide that are adjusting a couple of variables. I tried moving them to the base layer as well as a completely different slide to no avail. 

Susan Rice

Thanks Vincent. I will keep this guide on resolving suspend data limits handy. However, that I determined that was not what was causing the course not to bookmark appropriately when testing in our LMS test site. There wasa particular trigger that changes a variable that includes %Complete1% in it. That trigger that changed that variable for some reason was causing the problem. I removed that trigger and created a different type of trigger to accomplish the same task which alleviated the problem. If you look within the project file I attached, it was the "Set complete1..." trigger on button 1 on slide 2.3 that was creating my problem.