Corrupt Files & Slide Master Layers


I am hoping someone can assist. I have been away from publishing training for about 2 years. I had originally been using SL1 but have upgraded to SL2. This being my first course in SL2 I was excited that perhaps some of the bugs had been worked out.

In any case. I created a new file from scratch. On one of the slide masters I created a layer called "Error". I have a trigger on each slide that changes a variable to true when the timeline is complete. Prior to timeline completion the variable is false. I restrict users from moving forward in the presentation, so if they click the Next button before the slide is completed and the variable changed to true, the error layer triggers.

I have used this type of Error layer in most all courses I created in SL1. Well, in SL2 I'm finding this fairly simple system doesn't like to work. I had everything working fine when for apparently no reason, this function stopped working.

I read some of the threads on corrupt files and figured that I must have corrupted the files somehow. To attempt a correction, I created a new project and imported slides from the apparently corrupted file. All was good and the error layer worked again, yay.

I proceeded to publish. When viewing in Moodle, the Error function was gone again. I then went back to the SL2 files to see if the Error layer was still operational and low and behold it wasn't. It worked before publish and didn't work after. I did save the file after publishing (shouldn't have done that I guess).

Any idea of what's going on here? It's very frustrating. First course in SL2 and I'm finding buggy issues already. I'd really like to fix this layer issue and move forward.

Thanks in advance for any assistance you can offer.

5 Replies
Christie Pollick

Hi, Vaughan -- Thank so much for reaching out, and sorry to hear you are having difficulties! Have you had an opportunity to review this information on Unexpected or Erratic Behavior in SL2? You may want to run through the repair steps listed there to see if you find improvement. You may also want to share your file here so that others in the community are able to take a look at how things are set up and offer some suggestions. 

Vaughan Martin

Thanks Christie,

I have reviewed the erratic behaviour link. There is a possibility that my file name is too long or approaching the limit. The file location for my raw files in down about 7 or 8 files deep. This could be making the name too long. Not sure why It would cause layers to not work, but I can try to save the file in a different location. I don't think this will un-corrupt the file but hopefully it won't re-corrupt once I fix it again.

I had a similar post that Ashley responded to.

Once I get back to this project, I will upload one of the files to perhaps see what you guys see. However, because it worked and then didn't work, I think its a corrupt file issue. I've had corrupt files before and its very frustrating. I used to save about every 10-15min with a different file name (V1, V2, V3...) because I spent sooo much time fixing corrupt files. I just need to go back to that philosophy I guess. I love Storyline, I just wish it wasn't so buggy.

I'm going to post a link to this thread on the other discussion so I'm not doubling up on the threads.

Vaughan Martin


I attempted to fix my Slidemaster Layer problems but am now even more baffled. First, I moved all my files so that when saving the file mane would guarantee to be smaller than the Microsoft Limit.

I open my file and my SlideMaster Layer didn't return. I didn't expect it to be that easy. I then opened a new file and imported slides from the old file in an attempt to fix like I did before. No go, this didn't work the slide master layer still didn't work. I then proceeded to build another slide master layer using a different layout, I migrated a slide to this new layout in the hopes that the layer would work (thus I'd migrate all slides to new layout). Well, no go. The Slidemaster layer refuses to work.

I'm now faced with needing to do something more drastic (and much more time consuming) to fix this. With this issue, I learned my lesson again with Storyline, in that I need to begin saving every 10-15min with a new file name. But apart from that, I can't continue building if my end product continues to break (had the same issues with SL1). Its very time consuming to fix these buggy items. Thus I would really like to understand what happened here so I can avoid this in future.

Any assistance is greatly appreciated. I have attached a SL2 file, I hope it's not too big for the site.

Christie Pollick

Hi, Vaughan -- We appreciate the additional information and follow-up, and I think at this juncture, it may be best if we put you in touch with our Support Engineers to investigate your issues more closely. I will go ahead and create/submit a ticket on your behalf, and I will follow along with your case, so that I am able to share updates here in the thread for others who may benefit. 

You will be contacted via email after one of our Support Engineers have had the opportunity to review your file. Your patience is appreciated. 

Christie Pollick

Hi, Vaughan -- I just wanted to touch base with you on your case(s), as it appears that follow up emails were sent by our Support Engineers on 12/7/2015 at 12:06 PM for ticket #00706484, which is a duplicate of your first ticket #00690874 (and a response was sent on 11/11/2015 at 10:22 AM). Could you please check your SPAM folder, as the emails may have been redirected there if you still need additional assistance? Or, if your issue is now resolved, please also let me know so that I can mark both tickets as closed. Thanks so much!