email links not working

I have several projects that all have an email address in them that I want to be a live link for the student to be able to send a message to the instructor by clicking the link. I have highlighted the link and inserted the hyperlink for the trigger wizard to create the option to send the email out when they click the link. When the project is live on our LMS or on Articulate review you can hover over the link and the cursor changes to the pointing finger, but clicking the link does not launch an email window to send a message out. Am I missing a setting somewhere to make this work?

11 Replies
Whitney Lowe

It looks like this in the trigger wizard (see attachment). So, it sounds like the top trigger action needs to say "mailto:whitney@academyofclinicalmassage" instead of just the email address, is that correct? I didn't add the mailto as I didn't think it was necessary in the trigger wizard

Whitney Lowe

I tried adding the mailto: with the address so it read:

mailto:whitney@academyofclinicalmassage.com and it still didn't work. Since I am including the mailto:, should the trigger be to open a URL instead of send an email? And if so, why doesn't the send email action work in the trigger?

 

 

Vincent Scoma

Hi Whitney,

Happy to help!

When using the email trigger, there could be a couple of reasons why it doesn't appear to work as intended. Here are some things to consider when using this trigger: 

  • The learner must have an email client installed (for example, Microsoft Outlook), and they must have an email account configured in the app.
  • The email app must allow JavaScript and HTML submissions from external programs (in this case, Storyline). Some email apps, such as Lotus Notes and Groupwise, don't allow these features. As a result, email triggers won't work in these apps.

I tried to see if I could recreate the issue in a sample course using the Email Trigger. I wasn't able to replicate the issue since the trigger would open my email client as intended. Could I have you try testing this sample course to see if the trigger works for you: 

Please keep us updated and let us know if you have any questions! 

Farah Khan

Hi Everyone,

Is there any update on the send email trigger.

I am creating a course and want to use 'Send email to' but nothing is happening. I am using Outlook 2016. I also tried the link shared by 'Vincent Scoma' but no luck here as well. 

Please let me know if this trigger will work or not.

 

Katie Riggio

Hello Farah,

Thanks for reaching out, and I'm sorry to hear you're facing issues with the Send Email trigger!

In Whitney's case, our team recommended:

The Send to mail will attempt to open the email client installed on the user’s computer. It will not work if there is none.

The user will need to copy the email to use it. A Storyline slide will not allow you to copy from a textbox; however, a user can select text from a text-entry field.

I ran a quick test on Vincent's output, where the email client loads when clicking on the Send Email trigger. Here's a quick video of the experience and a few reasons why this option might not work smoothly.

To help us explore further, what browser(s) are you using to view the published output? Also, are you running an anti-virus program?

Vincent Scoma

Hi Nishma,

Thank you for sharing those details with us! 

As Katie mentioned, the Send Email trigger will attempt to open the email desktop application installed on the user’s computer. If the user doesn't have a desktop mail application, the trigger will not work. 

If that option doesn't work, another workflow is to create a "Copy Email" button that learners can click on to copy the email address. This will reveal a layer that contains the email for students to copy/paste into a new email. I am attaching an example file to this thread to show this layout. 

Please let us know if you have any questions!