9 Replies
Dave Cox

The story size the you set in Storyline is going to set the size of the published page, but It isn't uncommon for an LMS to add elements to the page, which will cause your published page to appear in the LMSs browser window different than you expect. I suspect that you are going to need to experiment with your LMS settings to determine the correct browser size window that will display the Storyline file the way you want. Try setting your browser width a bit narrower, or setting the height a little taller. 

Tristan Hunt

Using the standard story size you will always get the extra space on either side as the dimensions differ from the screen you are using.

I just went through a similar exercise. Check out this link: - https://www.articulate.com/support/storyline-2/how-to-determine-the-optimal-slide-size-for- mobile-devices-sl2

I ended up going for 16x10 display as it works best on the devices we use (Samsung note 10 and Samsung galaxy s5). As I have the menu in the top bar and no sidebar enabled I went for 1500x630 (1.5x the default for this size).

I have moodle set to launch the modules in a new window and I lock the storyline player at optimal size.

 

 

Ashley Terwilliger

Hi Richard, 

I'd defer to the community's expertise on Moodle, but if they're displaying the content in an iFrame, it's up to the iFrame to determine the display elements and as such items may be cut off as detailed here.  You'll want to reach out to your LMS Team for additional assistance.

Also, since you mentioned your overall story size and it looks like you added items to the player, I did want to share how that will impact your overall size. 

MarkAnthony Chesner

Hey Guys and Gals!

I know this in an old thread, but I have had similar problems and have found a solution for these gaps in the browser...

Go to your theme Custome CSS and add the following:

#page-mod-scorm-player {
overflow: hidden; /* Hide scrollbars */
margin-top: -15px;
margin-bottom: 0px;
margin-left: 0px;
margin-right: -40px;
padding-top: 0px;
padding-bottom: 0px;
padding-left: 0px;
padding-right: 0px;
}
#page-mod-scorm-player #scormpage #scorm_content {
height: 100%;
vertical-align: top;
}
/* Hide "Review mode" */
#page-mod-scorm-player #scormtop {
display: none;
width: 0px;
}

You will have to play with the settings and I realy don't know the value of the padding settings, just threw them in for good measure. It worked for me. There is only about 10 px off the bottom that I couldn't find a way to offset.

Good luck!!!!!!