Playback bar can’t control base layer and additional layers in sync?

Hi all,

I’m having a problem with timelines and layers in a software demo. I have two user audiences who, depending on their access type, see slightly different versions of some parts of the software. Rather than create two courses with nearly identical content and audio, aside from these few screenshots, I have the audience-specific screenshots on variable-driven layers that display based on the audience the learner identifies with at the beginning of the course. The audio throughout the course is the same for both audiences. On pages with audience-specific layers, I have the audio on the base layer and the screenshots on the audience-specific layers. In most cases, this has worked fine, but I’m running into problems when I have animations on those audience-specific layers, such as highlight boxes or highlight arrows. If you pause the timeline on those pages, the audio on the base layer pauses as it should, but the animations on the layers keep going (!). I have played with different slide layer property settings, but I have been unable to figure out a way to make the playback bar control the timelines on all layers. (I’m not sure why you wouldn’t want the playback bar to control both timelines, otherwise they can’t stay in sync.)

The only possible solution I can see is to remove the audio from the base layer, and put copies of it on each audience layer, and adjust the layer properties to allow seeking on those layers. However, it’s ridiculous to have two copies of the exact same audio on one slide, when I only need it once. This solution will make my course even bigger and cause potential problems if the audio and its captions are accidentally edited in one layer but not the other.

Is there another way to resolve this issue without resorting to audio duplicates? Am I just not seeing some special setting somewhere that will make the playback bar do what I want?

Thank you in advance!

11 Replies
Lisa Spirko

I can't wait around for a response anymore because my course is supposed to be going through peer and SME reviews this week, so I decided to try fixing the issue with duplicated audio on the slide layers and nothing on the base layer. Unbelievably, I'm having even more problems, from timeline syncing to playback bar buttons not working to the slide not advancing at the end of the layer timeline, and no combination of slide layer property settings seems to fix the problem. every time I think I'm fixing one issue, another one rears its ugly head. Articulate's claim that you can use layers for audience-specific content is a bunch of baloney, because this feature is so fraught with bugs that you can't tease it into working correctly. 

The only way I can see to get this to work now is to split my audience-specific layers onto separate slides and have the Next button on the previous slide advance to the correct one based on variables.

I'm so incredibly frustrated with layers right now that I'm going to do everything in my power to avoid using them ever again.

Leslie McKerchie

Hi Lisa,

So sorry to hear that you keep running into obstacles. 

Any chance you can share a sample of your project, perhaps a couple of slides in a .story file, so that we can take a look and understand what you may be experiencing?

Also, what version/update of Storyline are you using? You can find this information by opening your software > Help > About Storyline

Lisa Spirko

Hi Leslie. I can't share my course file, as it's proprietary, but I put together a mock-up with the same functionality. In Preview mode, select one of the audience types on the first slide, and then on the next slide, pause the timeline. The audio on the base layer will pause, but you'll see that the arrows on the slide layer keeps moving. It would be nice if Storyline included an option to pause both timelines simultaneously, or some other functionality to keep them in sync. Thank you for your help!

Alyssa Gomez

Hi Lisa!

The only way to control the seekbar of a layer is to enable the "Pause Timeline of Base Layer" setting. 

In that case, I'd actually remove the audio from the base layer, and place it on the slide layers instead. 

Check out the changes I made to your file -- let me know if that's what you had in mind!

Crystal Villareal

What are the advantages/disadvantages or pros/cons of placing the audio on the base layer versus throughout the layers on a slide?  I found one con (in my experience) to be that the layer will pause when clicking the pause button on the seekbar, but the audio does not stop if all audio is placed on the base layer rather than the correlating layer.  The only way I have found to get both layer and audio to pause (so as not to get the visuals out of sync with the audio) is to place the audio throughout the layers.  Thoughts?

Ashley Terwilliger

Hi Crystal, 

If you pause the timeline of the base layer, it'll pause everything, including any layers that are triggered through timeline elements.

If you're allowing Storyline to show more than one layer at a time, the audio would play through from all the layers. 

If I'm misunderstanding, perhaps you can share a copy of your file setup and we can take a look! 

David Oskorus

Hi Ashley-

I'm trying to do something similar, and finding it does not work that way:
"it'll pause everything, including any layers that are triggered through timeline elements."

If you set Allow seeking to Yes on the additional layer, the pause button pauses the additional layer but the main timeline continues to play.

If you set Allow seeking to No on the additional layer, the pause button pauses the main timeline but the additional layer continues to play.

Would love to be able to pause multiple layer timelines with the standard player pause button.
Perhaps I'm missing something... any thoughts?

Leslie McKerchie

Hi David,

Thanks for reaching out and sharing what you would like to do. 

Do you have a sample slide with multiple layers that we could take a look at to understand what you're running into?

With your permission, you can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.