Republishing Storyline course in HTML5 (that has Engage interactions)

I have a course that I'm republishing in HTML5 (to remove FLASH), but I have 4 slides that I created in Engage.  Those 4 slides are not behaving properly (asking for flash or being blank).  How do I fix those 4 Engage slides without having to re-do them in Storyline?

I opened the Engage interactions and resaved them.  Then I tried to re-insert them and just kept getting a spinning icon (it never inserted).  If I publish the Engage in HTML5 - how do I get it into Storyline as a separate slide?

Thanks for your help!

17 Replies
Katie Riggio

Hi, Debra. I'd love to look into this with you!

Were the interactions initially created in Engage '13? I ask because we're investigating an open issue where Engage '13 courses imported into Storyline 360 appear blank when using the Modern Player.

Let me know if that matches your setup. I'll be right here!

Leslie McKerchie

Hi CK1,

Thanks for contacting us to share what you are running into with your published output when adding an Engage interaction.

I created a test file and published it to HTML5 only and the course is viewing as expected.

  • Can you take a look at my published output here and let me know if you run into any issues?
  • If so, what browser are you viewing the content in?
CK1 CK1

Hi Leslie,

I figured it out. When I upgraded my SL file it doesn't automatically upgrade the Engage files within the course. I mistakenly thought this would be part of the upgrading. Turns out I have to go to each Engage file and manually upgrade them one by one. With large files this is a very slow task and most of the time SL/Engage isn't indicating that it's processing something. Only after upgrading each Engage file separately it will then publish to HTML5 only correctly.

Tony Morris

CK1 CK1,

I've tried doing as you suggested,  as I used to have to do when using Studio 09 Presenter and publishing both Engage and Quizmaker files when producing another Rev of our CBT. However, I've just opened and saved 4 Engage files in Storyline 3, hit publish and the Engage files aren't displaying/running. I've tried publishing to both Web and CD to no avail. FRUSTRATING to say the  very least for what is supposed to be an easy process.

On another note, I'm attempting to convert content produced and published using Studio 09 from Flash to HTML5 using Storyline 3 without much success. However, I've had far more success importing the original content into Storyline (0) making my tweaks and such, then opening with Storyline 3 and selecting "Upgrade." Regardless of which method there is still a lot of "heavy lifting" involved.

Any advice would be most welcome and appreciated.

Cheers,

Tony

Michael Law

Hello, I am looking at 30 individual courses that have been created across SL1, SL2, and S360.  I made sure to republish each one in S360 using HTML5 only as the publishing option. 

I am now understanding that while publishing in HTML5 only, it does not remove Flash dependency of some interactions within the courses. Is this correct? Users have been reporting that content is not displaying properly or the course is getting stuck.  Advising users to enable Flash has been the workaround, but come December 2020...this will no longer be a viable solution.

I am leaning towards updating and recreating these courses in Rise to make them more mobile friendly and HTML 5 exclusive.

What type of interactions (drag and drop, slider, hotspot, etc.) still rely on Flash? 

Tony Morris

Michael,

From my experiences to date I have no issues with quizzes using the Drag and Drop, Slider, Hotspots, etc. options.

My issue is with Engage files that were created using Studio 09. I've tried every feasible way to get them to work when I publish from SL3 to HTML5 only and they simply do not work.

I've reached out to the Articulate support folks for a solution and have not heard back from them to date. This has apparently been an issue for a number of years when reviewing the many posts and threads in these forums and there is no viable solution that I have came across.

I have 70 Engage files within my CBT (35 English and 35 French) that cannot contain Flash, which as you pointed out will not be supported on our customer's LMS very soon. I do not have the time, budget and resources to redo or replicate all those files within SL3. So I'm hoping that the Articulate software engineers can develop a viable solution in the immediate future.

Fingers crossed.

Stay safe!!

Cheers,

Tony

 

Lauren Connelly

Hi everyone!

Yes, we are still investigating a fix for the compatibility between Engage 09 and Engage 13, interactions that rely on Flash, and Storyline 360 that doesn't rely on Flash. 

We are continuing to update the bug report to gauge customer impact, so I appreciate everyone's comments. When we have more information, I'll make sure to report back to this discussion!

Maria Costa-Stienstra

Hi, everyone.

We appreciate your patience while our team investigated this.

I am happy to share some great news! We fixed the issue you reported where:
Modern Player: Engage '13 imported into Storyline 360 appears blank

Be sure to install the latest Storyline 360 update (Build 3.49.24347.0) to take advantage of all the recent features and fixes. 

If the problem happens again, please let us know, or you can always work directly with our support engineers here.