slider not resetting

Hi

I have a slider that doesn't reset when I return on the screen. It was resetting before when I had it in a layer. Now that it is on the main screen, it doesn't.

The slide properties I've tried are: automatically and reset to initial state, but none of them worked.

I've tried to change the state of the slider to "normal" when users click the last snip to jump to the next slide, but of course it doesn't work, since the state has not changed.

Is it normal that the slider stays in its final position? Is there a way to make the cursor go back to its initial position?

I've attached the scene for your feedback. Thank you in advance.

14 Replies
Gabriel Butler

Hi guys,

This looks like the perfect solution for me, but I don't exactly know how to "add a slide trigger that sets the slider variable to 0". Could someone please look at the attached screenshot of my trigger and let me know what I'm doing wrong?

Other info: I have 5 layers (the base layer, and 4 "other" layers). On each of the "other layers" is a slider, which I want to reset to the first step each time a user revisits a layer. Right now, if a user leaves a layer, and then navigates back to it later, the slider on that layer is still in the step/position it was left at (rather than resetting to the first step). Could someone please look at my trigger settings and let me know what the settings should be?
Thank you!!!!

Walt Hamilton

Set the operator to Assignment, the value to value and the one next to value to 0. Set it to when timeline starts and the object to the layer it is on, if you want it to be set to 0 when the layer starts.  For that to work, you must set the layer to reset to initial state, or the timeline won't restart.

Gabriel Butler

Hi Walt! Thank you so much for your very quick reply. I changed my trigger settings just as you described - but sadly it's still not working. The slider is remaining in the position I left it in, and it isn't resetting to the step prescribed in the trigger. I'm going to create a help request for this issue, and when I figure out what is going wrong, I'll reply back here. Thank you again for your help!

Katie Riggio

Hello Kathryn!

We haven't found a solution from Gabriel's case, but we are happy to keep digging!

If you could share the file, we'd love to take a closer look at the slide to offer more tailored support. Feel free to attach the file to this public discussion by using the Add Attachment button in your reply.

In the meantime, this conversation features a few ideas on how to reset a slider: