Trigger to change state of "next" button to normal not working

Hi there community,

I need a fresh pair of eyes, I think I'm overlooking something.

I was teaching some colleagues on Articulate Storyline 3 basics, and I was building a scenario whereby a user would have to interact with buttons on a slide before being able to progress to the next scene.

I created a trigger to change the state of the "next" button to normal based on the changing state of the buttons, however, it doesn't appear to be working. I created another text box with 2 states and gave it the same triggers as the next button - it is changing state just fine.

I do have a trigger to "change state of next button to disable when timeline starts", but as my slide behavior is set to "resume saved state", this trigger should only execute upon the first viewing of this slide - right?

Can someone take a look and let me know what I'm overlooking?

Story file attached. The triggers in question are on the "introduction to microbes" page.

To be clear, I am NOT looking for a workaround on how to get the desired behavior - I want to understand why the method I have put in here is not working. If I were building the course myself I would use a different method (using variables or whatnot) but this was too advanced for the group of users I was teaching. It didn't have the behavior I expected during my session with them so I would like to be able to tell them why and have us all learn from it.

 

Thanks all!

3 Replies
Stefano Craba

Hi Michelle;

the next button is chancing to normal correctly;
however the trigger to Disable the next button when the timeline start kicks in even if your slide is set to "resume saved state" each time the slide start again;

you would need an additional trigger to change the next button to normal when the timeline start if the state of the other objects is "magic..." see att.

hope it helps

 

Michelle M

Thank you Stefano.

It's very confusing to find that the "when the timeline starts" trigger kicks in every when the setting is set to "resume saved state". In my mind either the timeline is restarting or it isn't. My first thought had actually been to have the state of the next button triggered by the start of the timeline (as in your solution) but I thought it wouldn't work because I needed the settings as "resume saved state".

I suppose there is a difference between the "state" of the slide and the timeline of the slide. Just goes to show that the best way to learn is to teach!

Thanks for your help.