Videos not playing in published course. HELP!!

I am working on a course with lots of videos. Originally they were really blurry and so I've been having to use the work around I learned here. //

I published the course last week and the work around worked fine. Today I realized that some of the videos were not blurry because of SL, but because of the video themselves. Fixed the videos. Republished. Renamed the video files so I could replace them in the output file. Replaced them just like i did before.

Now when I open the output file (both web and LMS output) the videos do not play. They show up in preview mode, but not in the published version , HELP!!!

76 Replies
Ashley Terwilliger

Hi Michelle,

When you said you're opening the web and LMS version and viewing the "preview" mode - I'm not sure what you're describing. The preview option is within a .story file, and if you're testing the audio/video you'll want to publish a file and load it into the intended environment to fully test it. Testing it locally could cause you to encounter local security restrictions, and cause your content to fail. 


Since you mentioned no longer being able to play your audio or videos as of a specific time, it seems like a new development that it would first be good to check that you: 

  • Work on your local drive (your C: drive).Working on a network drive or a USB drive can cause erratic behavior, includingfile corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory pathto your project files and your published output is less than 260 characters(for example C:\Articulate).
  • Avoid using special characters, accents orsymbols in your file names.

Next, I'd conduct a repair of Storyline to see if the odd behavior is solved. 

Annette Downing

Michelle, I am having this issue with MP4's are you saying you converted them to AVI's and it worked? What's strange is my videos play in preview and when I publish some will play and others won't but then if I republish and play it different ones will work then the first time I published. It's not consistent. Let me know if converting them worked for you. Or if anyone else has some ideas I'd love to fix this issue!


Annette Downing

Hi Alyssa,
I’m using Storyline 3, I have tried publishing out to web and LMS. On Web I viewed from desktop and with LMS viewed from our LMS. Both reacted the same way. Any input would be greatly appreciated! I’ve tried reloading the videos and that still didn’t solve the problem. I’m thinking it has to be a publishing issue since they all work in the Articulate preview.


tc g

Hi.  We are having a similar-ish problem here.  We have courses (written in SL2) with 5 videos embedded which have been running for almost a year with no problems.  As of recently the videos have suddenly stopped playing.  We haven't updated the courses in anyway and the videos still play ok in articulate preview.  We can't see how to solve the issue!

Kim  Miller

I'm having the exact same problem. Have had exactly 20 emails (No Kidding!) back and forth with Articulate Tech Support and they are well-meaning but just send me documentation of how things are supposed to work all so well... but no solution for me. 

I just cannot get this to work. Extremely frustrating.
I just updated the Storyline 360 software. I published to LMS which for me is NEO.  I tried running the file on my LMS.
On my PC laptop running Chrome, yesterday only one out of four videos played. The video that played happened to be the one that I myself uploaded while all the videos from the Articulate Content Library failed to play. I republished yesterday and all videos played correctly, just once, in the LMS. I closed the browser and started over and in my LMS, only 3 of 4 played.

The results also did not calculate the scores correctly: I took my quiz responding to get 66%, which does show up correctly on my results slide, but the LMS reported a score of 100%.
And this is just me testing it on my computer. My students will be using iPads.  A few days ago I tested my Storyline file that I had published for LMS, using an iPad, and only one of the four videos played correctly (again, the one I had made myself). All were coded the same in the Storyline software - play automatically, etc.

If I can't get this fixed, I won't purchase the subscription.This is a big deal to me because I was hoping to begin a business centered on using Storyline to create SCORM for use with LMS and users with iPads, particularly.

I'll attach my zipped file for you to look at. 

Slide 1.4 should be False; 5 is True; 6 is False. d/ 0B01QMpEkkogXWVpBTmthMWhVcXM/ view?usp=sharing


Joanna Cloutier

Hey there folks,

I am having the same problem.  I am on a Windows 10 Desktop.  My course content and video files are saved locally with a short file folder path.  I have tried AVI/MP4/WMV in powerpoint and I can play the video no problem in PowerPoint but when I publish it or preview it in Articulate it doesn't work.  I have reinstalled the entire Articulate suite to see if that would help - it didn't.  I have also checked for updates, there are none.  My current version of Articulate 13 is update 9 1702.2417.

I would prefer not to post video here...please email me for PM.

Will Findlay

I am finding a similar problem, but it is with consistency of playback. I have a video in a course set to play automatically when the user reaches the second slide -- it plays most of the time, but sometimes the progress bar just moves forward without the video playing. If the user scrubs the progress bar, it immediately starts playing as it is supposed to, but not everyone knows to try that. This happens in both Articulate Review and in our LMS. The course is set to open full screen and the story size is 960 x 540. Storyline 360 latest version. HTML5 playback.

Ashley Terwilliger

Hi Will and Kim, 

I took a look at Joanna's case as the most recent post here, and since you're both using Storyline and not Presenter it's likely different (she wasn't inserting the videos through the Presenter tab, but through Powerpoint which is likely the cause of her issue). 

Will, what browser are you viewing the videos in? The automatic playback is something that we've seen recently in Safari.  

  • If you're using another browser, could you share a bit more about that and a link to your course in Review?
  • Also what settings have you set up for the videos playback - I assume you're using the Video properties of start automatically or a trigger to play when the timeline starts?
  • Is it only on this second slide that the video doesn't load? Does refreshing the browser cause it to play immediately? Are any other slides running into this?

Kim, I'm sorry to hear that, and I saw you did some initial testing of this issue with my colleague Eloisa. If you'd like to continue working with her to resolve the issue or help us understand the cause we'd be more than happy too. If not, I also understand that and I hope you have a happy Thanksgiving. 🙂

Will Findlay

Regarding the browser, I am seeing this in Chrome and IE 11. 

Unfortunately it isn't really easy for me to share my course because it is internal facing. I would have to recreate it which I don't have time to do. Basically there is one intro slide that must be advanced manually, followed by a slide that contains a video filling the entire presentation area. The video starts automatically (Video properties). It uses the built in seekbar rather than the video controls.

To get the video to play, all the user needs to do is scrub the seekbar a tiny bit, or go back a slide and come back. But unfortunately some people don't intuitively try this trick.

By the way, my video has captions, so maybe the captions are the culprit?

The good news is that I think I did find a potential workaround for my issue with videos not playing on occasion.

Here is what I did:

I scooted the videos, set to play automatically, back one second on the timeline so they start at one second in. This seems to have fixed the issue, at least in my very limited testing. My theory (superstition?) is that it gives the code a little time before trying to play the video. Either that, or it is wishful thinking on my part. I'll let you know if I see the issue again.


Ashley Terwilliger

Hi Will,

If you set the videos to not play automatically then they'll wait for a user input to play, but the slide timeline will still start.

The method you described of starting the video a second (or even half a second) into the slide timeline is something I've seen other users mention for audio issues where it's taking the browser/device/connection a bit of time to catch up with the loading of content. Another good method for testing that it to play it from a few different set ups and connections to see if there is a noticeable difference in playback. 

James Washok

So it seems that this is an on-going issues that has yet to be resolved. I am working with Storyline 3 and have the same problem; videos not automatically playing. I have tried every trick and tip mentioned previously and none of them work (moving it one second into the timeline, publishing as Flash with HTML backup, even adding a .25 second automatically moving forward slide BEFORE the video slide...).

WHAT is the issue and what is the resolution for it? And, before I am asked, no, I cannot provide a copy of what I am working on as I work in aviation and this is confidential information/training we are developing for an OEM.

If all fails, like others, I will just have to move into Captivate or PowerPoint.

Alyssa Gomez

Hi there James,

Really sorry for the trouble you're running into. Is this problem happening after the course is published? If so, what web browser were you using?

Some recent changes in Google Chrome and Safari have affected how video autoplay is handled in Storyline 3. The articles linked there include steps you can follow to fix this issue.

Let me know if that helps, or if the problem is happening in a different browser. We'll keep digging if we need to!

James Washok


Thanks for reaching out. I have noticed that if I open the HTML in another browser (IE...we don't have Windows 10/Microsoft Edge in my company yet), and "allow blocked content", it works. So it does look like it's an issue with Chrome, which is what I use as a default browser.

However, I also noticed that if you create an initial slide, set it to advance automatically, and then place an auto-play video on the next slide, that also fails to work. The ONLY way I have been able to get a video to auto-play so far is to force the user to advance the slide through using the NEXT button; then, the video works as desired. It's driving me nuts, but it's a bandaid for now.

James Washok * Instructional Designer
FlightSafety Operations * 4800 Diplomacy Road * Fort Worth, TX, 76155
Tel: 817.554.7223 * Cell: 972.795.5493 * * A Berkshire Hathaway company

Leslie McKerchie

Hey James!

We added support for Chrome's new behavior to yesterday's update for Storyline 3. Install the latest update and republish your course.

Learners using Chrome 66+ now see a play button when they launch or resume a course with a video on the first slide. Clicking the play button starts the course and allows the video to play. Videos on other slides should autoplay as expected.

It looks like your email signature came through when you replied via email. You can remove that if needed by clicking ‘Edit’ beneath your response. Here’s a quick Peek video if you need help.